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1 TEST RESULTS 
Modification history: 
Version Date Who Comment 

v1.0 09/20/10 Stephen Rodriguez  Initial test plan created 
V2.0 11/28/10 Stephen Rodriguez Test Results 

1.1 Introduction 
1.1.1 Overall Objective for Software Test Activity 

• The objective for the Software Test Activity is to ensure that the mobile application meets all of the standards of the 
client, as well as ensuring the software runs without any errors.  

• The software test effort should be able to catch any bugs in the application. By catching the errors in the test effort, it will 
ensure that application of the highest quality will be delivered to the client. 

1.1.2 Reference Documents 
• Concept of Operations  
• Project Management Plan 
• Software Requirements Specification 

1.2 Description of Test Environment 
The hardware that will be used to test the mobile application will be a mobile phone running at least the Android 1.6 operating 
system. Also, when developing the software, an Android simulator will be used. The testers will include both the developers of the 
software and users who have never used the application before. The application will be tested on multiple phones running different 
versions of the Android operating system. 

1.3 Overall Stopping Criteria 
Testing will continue until a fatal error has been reached. All of the errors prior to the fatal one will be recorded. The list of errors 
will then be replicated and corrected, including the fatal error. 

Once no errors are found during a test run, the software will be thoroughly tested by each team member to provide a sufficient 
amount of test cases for the error-free software. 

A product that is considered “good enough to deliver” is a product in which there are no known errors in the cosmetics and the 
software. 

1.4 Description of Individual Test Cases 
Test Objective Test Description Test Conditions Expected Results 
The ability to connect to the 
website. 

The user will run the 
application 

Running the application to 
ensure the user is testing in a 
new session 

The application will boot up 
completely in a sufficient 
amount of time. 

The ability to select one of 
the five main sections; US, 
World, Money, 
Entertainment and Sports.  

The user has the option to 
select each of the 5 news 
sections 

Running the application to 
ensure the user is testing in a 
new session 

The application will be able to 
load each section 
successfully. 

The ability to have a “show 
more” button. 

The user will be shown 5 
articles per section. If the 

Running the application to 
ensure the user is testing in a 

When the user selects the 
“show more” button, a longer 
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Test Objective Test Description Test Conditions Expected Results 
user wants to read the rest of 
the stories, he/she will be 
able to select a “show more” 
button and the full story will 
be shown 

new session list of articles show. 

The ability to read an article The user selects an article 
desired to read 

Running the application to 
ensure the user is testing in a 
new session 

The user is able to read the 
article with the use of the 
application.  

The ability to jump between 
News Sections from within 
the Article lists 

When the menu button is 
selected, the user has the 
ability to select a different 
section besides the section 
he/she is in 

Running the application to 
ensure the user is testing in a 
new session 

The user is able to switch 
between sections without 
going back to the main menu 

The ability to long-click the 
article to get the Article’s 
options menu 

When the user selects and 
holds the selected article, the 
Article’s options menu 
appears 

Running the application to 
ensure the user is testing in a 
new session 

The user is able to view the 
Article’s options menu by a 
long-click 

The ability to mark an article 
as read 

When an article has not been 
read, the article title’s font is 
in blue 

Running the application to 
ensure the user is testing in a 
new session 

The user knows the article 
has not been  read,  when the 
article title’s font is in blue 

The ability to mark an article 
as unread 

When the article has been 
read, the article title’s font 
becomes purple 

Running the application to 
ensure the user is testing in a 
new session 

The user knows the article 
has been  read,  when the 
article title’s font is in purple 

The ability to receive an error 
message if the device does 
not have internet access 

When the user is until to gain 
internet access, an error 
message appears to let the 
user know of the lack of 
internet accessibility 

Running the application to 
ensure the user is testing in a 
new session 

An error message is displayed 
informing the user about lack 
of internet connection 

The ability to refresh the 
article lists 

The user is able to refresh the 
article to ensure update 
articles are available 

Running the application to 
ensure the user is testing in a 
new session 

The application has the most 
up to date article available for 
the user 

1.5 Test Results 
Test Tester Date tested Test environment Test Result 
The ability to connect to 
the website. 

Andy Harmic, 
Stephen Rodriguez 
and Tyler Zaino 

11/28/10 Android Emulator, Version 1.6 
firmware and Version 2.2 
firmware. 

Successful connection to 
the website. 

The ability to select one 
of the five main sections; 
US, World, Money, 
Entertainment and 
Sports.  

Andy Harmic, 
Stephen Rodriguez 
and Tyler Zaino 

11/28/10 Android Emulator, Version 1.6 
firmware and Version 2.2 
firmware. 

Successful ability to 
select one of the main 
sections. 

The ability to have a 
“show more” button. 

Andy Harmic, 
Stephen Rodriguez 
and Tyler Zaino 

11/28/10 Android Emulator, Version 1.6 
firmware and Version 2.2 
firmware. 

Successfully about to 
view more articles upon 
request 

The ability to read an 
article 

Andy Harmic, 
Stephen Rodriguez 
and Tyler Zaino 

11/28/10 Android Emulator, Version 1.6 
firmware and Version 2.2 
firmware. 

Successfully loaded an 
article for the user to 
read. 
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Test Tester Date tested Test environment Test Result 
The ability to jump 
between News Sections 
from within the Article 
lists 

Andy Harmic, 
Stephen Rodriguez 
and Tyler Zaino 

11/28/10 Android Emulator, Version 1.6 
firmware and Version 2.2 
firmware. 

Successfully able to 
switch between sections 

The ability to long-click 
the article to get the 
Article’s options menu 

Andy Harmic, 
Stephen Rodriguez 
and Tyler Zaino 

11/28/10 Android Emulator, Version 1.6 
firmware and Version 2.2 
firmware. 

Successfully able to 
obtain the article’s 
option menu after a 
long-click 

The ability to mark an 
article as read 

Andy Harmic, 
Stephen Rodriguez 
and Tyler Zaino 

11/28/10 Android Emulator, Version 1.6 
firmware and Version 2.2 
firmware. 

Successfully marks read 
articles 

The ability to mark an 
article as unread 

Andy Harmic, 
Stephen Rodriguez 
and Tyler Zaino 

11/28/10 Android Emulator, Version 1.6 
firmware and Version 2.2 
firmware. 

Successfully marks 
unread articles.  

The ability to receive an 
error message if the 
device does not have 
internet access 

Andy Harmic, 
Stephen Rodriguez 
and Tyler Zaino 

11/28/10 Android Emulator, Version 1.6 
firmware and Version 2.2 
firmware. 

An error successfully 
displays when the device 
does not have internet 
access.  

The ability to refresh the 
article lists 

Andy Harmic, 
Stephen Rodriguez 
and Tyler Zaino 

11/28/10 Android Emulator, Version 1.6 
firmware and Version 2.2 
firmware. 

Successfully able to 
refresh the article lists 

1.6 Conclusion 
Once our code was written, we were able to successfully use the application. The application itself works wonderfully. The only 
problems in testing was the use of the 1.6 firmware, it sometime suffered “force close” messages and was a little bit slower loading 
the application/articles. We believe this may be due to the older and slower software available to the phones and not a problem in 
our application. However, other than speed, the application seemed to work excellent for the android phones. 

2 USER’S MANUAL 
Modification history: 
Version Date Who Comment 

v1.0 11/26/10 Karl Banks  Initial User’s Manual 
v2.0 11/27/10 Tyler Zaino User’s Manual complete 

2.1 System Description 
The CNN NewsApp is a mobile application that delivers news directly to any Android device running the application. It retrieves news 
from five different sections, World, US, Money, Entertainment and Sports. The application allows the user to first pick which section 
of news they would like to read, and from there they are presented with the article title along with a short description. The user 
then has an option to either open the article in the application, or they have the option to open it within the Android device’s built-
in browser. Also the application allows the user to search through older articles by using the “See More” option located at the end of 
the article list. 

2.2 System Requirements    
• Android Phone 
• Android OS 1.5 or higher 
• Internet Connection (Wi-Fi or 3G) 
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2.3 User’s Manual 

 

1. Open the application by clicking the NewsApp icon. 

 

2. Once the application is fully loaded, the user is presented with 
the main screen. Here the user can select which subject of news 
they would like to read. 
 

 

3a. By clicking the subject, the user is then presented with a list 
of articles grabbed from the CNN website. 
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3b. If the user is not satisfied with the articles presented, they 
are able to see more articles by scrolling to the bottom of the 
article list and clicking “Show More” 
 

 

4. Once the user finds an article they are interested in, they are 
able to simply click the article and load it into the application. 
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5. The user is also presented with more options by long-clicking the article in the article list. 
 

• Open article – Simply opens the article within the application. 
• Open article in Browser – Opens the article within the Android devices built-in browser. 
• Mark as Read/Unread – Marks or unmarks the article in the article list to show if the article has been read or not. 
 

 
 

 

6. At any time, if the user wants to jump to another genre of 
news, they can simply click the Menu button on the Android 
device. 
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3 SOURCE CODE 
Visit http://ucf.karlbanks.com/cop4331/deliverables.php to obtain the latest copy of the Source Code. The downloadable file, 
SourceCode.zip, contains the following: 

• NewsApp.zip 
• jsoup-1.3.3.jar 

 
Note that both of these files are required to execute the News Phone Application. For more information, see the Build Instructions in 
Section 4 of this document. 

4 BUILD INSTRUCTIONS 
The following build instructions assume that the developer is using Eclipse, with ADT, and that the appropriate Android SDK 
(Windows, Mac, Linux) has been installed. For more help, please see the Quick Start section below. 
 
For other IDE instructions, please visit http://developer.android.com/guide/developing/other-ide.html. 

4.1 Before You Begin 
NewsApp's intended target is Android 1.6. Therefore, it is REQURIED that SDK Platform Android 1.6, API 4, revision 3 be an installed 
package on your development computer. However, NewsApp WILL RUN with Android 1.6 or HIGHER, so your AVD may target 
Android 1.6 or HIGHER. 

4.2 Required Libraries 
The NewsApp project is dependent on the jsoup-1.3.3 or HIGHER java library. A copy can be obtained from 
http://ucf.karlbanks.com/cop4331/deliverables.php (in the SourceCode.zip package) or directly from http://jsoup.org/download. 
 
Download the .jar file to the desired location on your file system. Instructions on how to reference the file will be detailed in 
Configuring Build Path section below. 

4.3 Developing in Eclipse, with ADT 
1. Download the SourceCode.zip file from http://ucf.karlbanks.com/cop4331/deliverables.php. 
2. Extract the file contents to the desired location on your file system. 
3. Launch Eclipse IDE. 
4. Click File > Import... from the Eclipse menu bar. 
5. Select General > Existing Projects into Workspace 
6. Click on the Next > button. 
7. Click on the Browse... button under Select root directory. 
8. Navigate to the location where you saved the NewsApp project. 
9. Select the NewsApp folder and click the OK button 
10. The project should be selected in the Projects table. 
11. Make sure the field Copy projects into workspace is selected. 
12. Click on the Finish button. 
13. The NewsApp project should now be open in your Package Explorer. 
14. Please see the Configuring Build Path section below before continuing. 
15. If you haven't already created an AVD, see the Creating an AVD section below. 
16. To run NewsApp in the emulator, please see the Running on the emulator section below. 
17. To run NewsApp on a device, please see the Running on a device section below. 

http://ucf.karlbanks.com/cop4331/deliverables.php�
http://developer.android.com/guide/developing/other-ide.html�
http://ucf.karlbanks.com/cop4331/deliverables.php�
http://jsoup.org/download�
http://ucf.karlbanks.com/cop4331/deliverables.php�
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4.4 Quick Start 
The steps below provide an overview of how to get started with the Android SDK. For detailed instructions, start with the Installing 
the SDK guide. 

4.4.1 Prepare Your Development Computer 
Read the System Requirements document and make sure that your development computer meets the hardware and software 
requirements for the Android SDK. Install any additional software needed before downloading the Android SDK. In particular, 
you may need to install the JDK (version 5 or 6 required) and Eclipse (version 3.4 or 3.5, needed only if you want develop using 
the ADT Plugin). 

4.4.2 Download and Install the SDK Starter Package 
Select a package and download it to your development computer. To install the SDK, simply unpack the starter package to a safe 
location and then add the location to your PATH. 

4.4.3 Install the ADT Plugin for Eclipse 
Set up a remote update site at https://dl-ssl.google.com/android/eclipse/. Install the Android Development Tools (ADT) Plugin, 
restart Eclipse, and set the "Android" preferences in Eclipse to point to the SDK install location. For detailed instructions, see 
ADT Plugin for Eclipse. 

4.4.4 Add Android Platforms and Other Components to Your SDK 

Use the Android SDK and AVD Manager, included in the SDK starter package, to add one or more Android platforms (for 
example, Android 1.6 or Android 2.2) and other components to your SDK. If you aren't sure what to add, see Which components 
do I need? To launch the Android SDK and AVD Manager on Windows, execute SDK Setup.exe, at the root of the SDK directory. 
On Mac OS X or Linux, execute the android tool in the <sdk>/tools/ folder. For detailed instructions, see Adding SDK 
Components. 

4.5 Configuring Build Path 
If installed, the proper Android library (Android 1.6) will automatically be referenced after the NewsApp project is imported into 
your Eclipse workspace. However, two or more error messages will prevent the application from running. The errors are due to a 
missing library (jsoup-1.3.3 or HIGHER). The following instructions detail how to provide a reference to the missing jsoup library: 
 

1. Right click on the NewsApp project in the Package Explorer. 
2. Select Build Path > Configure Build Path... 
3. Under the Libraries tab, select the missing jsoup-1.3.3.jar file. 
4. Click on the Edit... button. 
5. Navigate to the location where you saved the jsoup .jar file. 
6. Select the jsoup-1.3.3.jar or HIGHER. 
7. Double click or click on the OK button to select the file. 
8. Click on the OK button to finish referencing the jsoup library. 
9. The error messages should disappear and NewsApp can now be run. 

4.6 Creating an AVD 

An Android Virtual Device (AVD) is a device configuration for the emulator that allows you to model real world devices. In order to 
run an instance of the emulator, you must create an AVD. 
 
To create an AVD from Eclipse: 

1. Select Window > Android SDK and AVD Manager, or click the Android SDK and AVD Manager icon in the Eclipse toolbar.  
2. In the Virtual Devices panel, you'll see a list of existing AVDs. Click New to create a new AVD.  

http://developer.android.com/sdk/installing.html�
http://developer.android.com/sdk/installing.html�
http://developer.android.com/sdk/requirements.html�
http://java.sun.com/javase/downloads/index.jsp�
http://www.eclipse.org/downloads/�
https://dl-ssl.google.com/android/eclipse/�
http://developer.android.com/sdk/eclipse-adt.html�
http://developer.android.com/sdk/installing.html#which�
http://developer.android.com/sdk/installing.html#which�
http://developer.android.com/sdk/adding-components.html�
http://developer.android.com/sdk/adding-components.html�
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3. Fill in the details for the AVD.  
Note: Be sure to define a target for your AVD that satisfies NewsApp's Build Target (Android 1.6 or HIGHER). 

4. Click Create AVD.  
 
Your AVD is now ready and you can close the SDK and AVD Manager, create more AVDs, or launch an emulator with the AVD by 
selecting a device and clicking Start. 
 
For more information about AVDs, read the Android Virtual Devices documentation. 

4.7 Running on the Emulator 

Before you can run NewsApp on the Android Emulator, you must create an AVD. 
 
To run (or debug) NewsApp, select Run > Run (or Run > Debug) from the Eclipse menu bar. The ADT plugin will automatically create 
a default launch configuration for the NewsApp project. Eclipse will then perform the following: 

1. Compile the NewsApp project (if there have been changes since the last build).  
2. Create a default launch configuration (if one does not already exist for the project).  
3. Install and start NewsApp on an emulator (or device), based on the Deployment Target defined by the run configuration.  
 

If debugging, NewsApp will start in the "Waiting For Debugger" mode. Once the debugger is attached, Eclipse will open the Debug 
perspective. 
 
To set or change the launch configuration used for NewsApp, use the launch configuration manager. See Creating a Launch 
Configuration for information. 

4.8 Running on a Device 

Before you can run NewsApp on a device, you must perform some basic setup for your device: 
• Declare NewsApp as debuggable in the manifest  
• Enable USB Debugging on your device  
• Ensure that your development computer can detect your device when connected via USB 

 
Read Setting up a Device for Development for more information. 
 
Once set up and your device is connected via USB, install NewsApp on the device by selecting Run > Run (or Run > Debug) from the 
Eclipse menu bar. 
 
 
*Portions from Android's Dev Guide: http://developer.android.com/guide/developing/eclipse-adt.html 

  

http://developer.android.com/guide/developing/tools/avd.html�
http://developer.android.com/guide/developing/eclipse-adt.html#AVD�
http://developer.android.com/guide/developing/eclipse-adt.html#launchconfig�
http://developer.android.com/guide/developing/eclipse-adt.html#launchconfig�
http://developer.android.com/guide/developing/device.html#setting-up�
http://developer.android.com/guide/developing/eclipse-adt.html�
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5 PROJECT LEGACY 
Modification history: 
Version Date Who Comment 

v1.0 10/21/10 Jason Heintz Initial pass through 
v2.0 10/22/10 Aaron Birencwaig Worked on Analysis section 
v3.0 10/28/10 Jason Heintz Worked on Roles section 
v4.0 10/29/10 Jason Heintz Final compilation of document 

5.1 Roles 

Project Work Team Members % per Member 
Team Webpage Karl Banks 100 

Concept of Operations 
Karl Banks 50 
Tyler Zaino 50 

Software Requirements and 
Specifications 

Jason Heintz 50 
Aaron Birencwaig 50 

Project Management Plan Andy Harmic 100 

Project Management Report 
Andy Harmic 50 

Karl Banks 50 

High-Level Design 
Andy Harmic 50 

Karl Banks 50 

Detailed Design 

Jason Heintz 25 
Tyler Zaino 25 

Aaron Birencwaig 25 
Stephen Rodriguez 25 

Test Plan Stephen Rodriguez 100 

Test Results 
Stephen Rodriguez 70 

Tyler Zaino 15 
Andy Harmic 15 

User’s Manual 
Karl Banks 50 
Tyler Zaino 50 

Build Instructions Andy Harmic 100 

Project Legacy 
Jason Heintz 50 

Aaron Birencwaig 50 

5.2 Analysis 

5.2.1 Assessment of the Quality of the Final Product 
The quality of the final product is very high.  The application works very well and covers all requirements and expectations, 
while still being user friendly.  The product will work under almost any circumstances experienced by the phone except for that 
of catastrophic. 

5.2.2 Recommended Use of the Final Product 

The News Phone Application is targeted for those people that are always on the go and who still like to keep updated in what is 
happening in the news.  The application can run on the latest Android phones and can be used at all times of the day.  The only 
requirement needed by the application is an internet connection, which is either obtained through phone’s cellular signal or 
WiFi signal.  
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5.2.3 Known Problems 

At this current date, we do not have any outstanding problems with the product.  All problems that were found during 
development and testing were taken care of immediately.  There are areas in which improvement may be desired, but there are 
currently no know problems with the News Phone Application. 

5.2.4 Adherence to Project Plan 

We have followed our project plan very closely and stayed exactly on time or ahead of schedule the entire course of the 
semester. Our project estimates, as far as time concerns, were all met.  Since we made the estimates reasonable and realistic, 
we were able to adhere all deadlines. We did not have any deviations from our estimates because we took accurate guesses and 
with the combined efforts of the team, and we were able to complete the project and even provide over and above what was 
required. 

5.2.5 Defect Analysis  

There are no known defects in our phone application.  Our application is small scale and the software development model that 
we used proved to be successful. We were able to create our code and test it without any errors detected in every case that we 
could possibly think of. Every version that we have works flawlessly to our knowledge, the only difference being the end 
versions are highly embellished with cosmetic and speed enhancing features. 

5.2.6 Quality Assurance 

We believe that the testing and quality assurance activities that we performed on the application were very adequate.  We tried 
to test the application under any circumstance that we could foresee the end user using the application.   The testing and QA 
was conducted in a timely manner, but the only suggestions we have for possible improvement is to have outsiders, unfamiliar 
with the product, test it for effectiveness. 

5.2.7 Configuration Management 

Our configuration management plan went very well.  We specified in deliverable 1 that our plan was, “We will use Subversion to 
handle version and change control. Karl will be responsible for managing the version control software and repository. Every 
team member should make an effort to learn Subversion and the general procedures for working with a version control system. 
If we have difficulty using Subversion, we will resort to email to ensure that every team member has the most recent version of 
the project.” Our practices were quite sufficient and we were all able to access the most recent version almost always at our 
will. Because our Configuration Management plan worked so well, I don’t think that there is anything that I would say that we 
could have improved on in this area. 

5.2.8 Suggestions for the Future  

Our project went extremely well with very few setbacks, with this being said, there is really no need for changing the way that 
we approached it on projects of similar size. The suggestions for future teams would be to stay on schedule and not fall behind, 
make realistic expectations and utilize all of the teams members strengths, try to find a webs source for getting news updates 
from a news site that allows users to take its’ articles for mobile news applications, and making the code created is easy to use 
with other news sites in order to make the project reusable and profitable if other customers are interested in purchasing a 
similar product. For a project of 10 or even a 100 times this size, again all the things above would still apply, but focusing more 
on setting accurate time tables, understand that not everything could be predicted so allowing lapse times, and making sure 
everyone’s strengths are being fully utilized would be critical. In addition, more team members or a far larger time frame would 
be necessary for something larger as this phone application project was quite appropriate for the time allotted. 


